작성일자
카테고리 워드프레스/워드프레스 일반

업그레이드라는 말은 많이 들어봤지만 다운그레이드라는 말은 좀처럼 듣기 힘들죠. 워드프레스를 업그레이드 했는데 기존의 테마나 플러그인과 호환되지 않아 에러가 발생하면 다운그레이드가 필요합니다. 방법은 간단하며 수동 업데이트 방법과 동일합니다.

 

로컬호스트를 기준으로 설명합니다. 우선 만일을 위해 워드프레스 폴더를 복사해 백업합니다.

 

 

또한 데이터베이스도 백업합니다. phpMyAdmin에 들어가서 데이터베이스를 선택하고 내보내기 탭을 선택, 실행 버튼을 클릭해 백업한 워드프레스 폴더에 저장합니다.

 

https://ko.wordpress.org/releases/#older

 

워드프레스 이전 버전 페이지로 가서 원하는 워드프레스 버전을 선택합니다.

 

 

zip 링크를 클릭해 내려받습니다.

 

압축 해제하고 폴더 안으로 들어가 wp-content 폴더를 제외하고 모두 선택한 다음 복사합니다.

 

 

다운그레이드 할 워드프레스 폴더에서 wp-admin과 wp--includes 폴더를 삭제합니다. 복사해 온 파일 및 폴더를 붙여넣습니다. 중복되는 파일은 덮어쓰기 합니다.

 

 

워드프레스를 새로고침하면 위와 같은 메시지가 나타납니다. 워드프레스 데이터베이스 업데이트 버튼을 클릭하면 완료입니다.

 

 

계속 버튼을 클릭하면 새로운 버전의 관리자 화면이 나타납니다.

 

 

상단에 새로운 버전을 설치하라는 메시지가 나오고 업데이트도 많습니다. 이들 메시지를 나오지 않도록 하려면 별도의 플러그인을 설치합니다.

 

 

플러그인 추가하기 화면에서 Disable All WordPress Updates로 검색해 설치하고 활성화 하면 됩니다.

 

워드프레스 코어나 플러그인은 항상 최신 버전으로 유지하는 것이 좋습니다. 구버전을 사용하면 보안에 취약하기 때문입니다. 내컴퓨터의 로컬호스트에서 작업할 경우는 위와 같이 업데이트를 비활성화 해 사용할 수 있는 것입니다.

 

 

워드프레스를 다운그레이드 한 이유는 페이지 빌더 플러그인이 제대로 작동하지 않기 때문인데 이제는 제대로 작동합니다.

 


 

 

 

저작자 표시 비영리 변경 금지
신고

티스토리 툴바