작성일자
카테고리 워드프레스/워드프레스 쇼핑몰

오늘 날짜로 우커머스(WooCoomerce) 쇼핑몰 플러그인 2.1 버전이 발표됐습니다. 이전 버전과 많이 다르므로 2.0 버전 사용자는 업데이트를 주의 해야 합니다. 왜냐하면 이전 버전은 상점 관련 페이지가 반응형이 지원되지 않았지만 이번 버전은 반응형을 지원하기 때문에 스타일시트가 많이 변경돼 서로 충돌이 일어나며 레이아웃이 엉망이 됩니다.



우커머스용 프리미엄 테마 사용자도 우커머스 2.1을 지원하는 업데이트 버전이 나올 때까지는 업데이트 하면 안됩니다. 시험삼아 우커머스를 업데이트 하고자 하는 분은 반드시 데이터베이스를 백업해서 레이아웃 오류가 발견되면 이전 버전으로 복구해야 합니다.


새 버전을 시험하고자 하는 분은 가능한한 로컬호스트에서 새로운 워드프레스를 설치하고 실험하는 것이 좋습니다. 일부 프리미엄 테마는 바로 사용이 가능합니다. 



새로 설치하는 경우 플러그인 설치하기 화면에서 WooCommerce로 검색하면 2.1 버전이 나오며 설치하면 한글 언어파일도 같이 설치됩니다.



이전 버전과 달리 주메뉴 알림판의 하위 메뉴에서 우커머스의 초기화면을 볼 수 있습니다.



이전 버전과는 달리 우커머스 스타일시트를 비활성화 하는 부분이 사라졌습니다. 그래서 이 옵션을 비활성화 해야 하는 프리미엄 테마는 스타일시트 충돌이 일어나 레이아웃이 제대로 표현되지 않습니다. 



우커머스를 지원하는 테마는 두 종류로 나뉩니다. 다용도(Multi Purpose) 테마의 경우 상점 기능 외에 특별한 기능은 별로 없습니다. 다양한 웹사이트를 만드는 테마이기 때문이죠. 이런 테마는 우커머스 2.1 버전을 사용해도 레이아웃의 충돌이 없습니다. 우커머스의 기본 레이아웃을 그대로 사용하기 때문입니다. 위 테마는 The7이라는 다용도 테마입니다.



우커머스를 지원하는 또 하나의 테마는 우커머스 전용 테마입니다. 이런 테마는 우커머스의 레이아웃을 변경하면서 결제페이지나 장바구니 페이지, 상세 페이지, 상점 페이지를 만들기 때문에 우커머스의 스타일시트를 비활성화 해서 테마를 사용합니다. 그런데 우커머스 2.1 버전에서는 이런 비활성화 옵션이 없기 때문에 테마가 2.1 버전과 호환성을 갖춰 업데이트 될 때까지 기다려야 합니다. 단순히 우커머스 스타일시트를 제거하는 것만으로는 해결이 안됩니다. 


위 테마는 일반 웹사이트 뿐만 아니라 우커머스 쇼핑몰의 기능도 충분히 지원하는 보기 드문 테마입니다. 이런 우커머스 전용 테마는 위에서 보는 바와 같이 상점페이지인데도 블로그 사이드바가 나타나고 이미지도 작게 나옵니다. 우커머스 스타일시트를 비활성화 할수가 없고 파일을 제거하더라도 레이아웃이 제대로 표현되지 않습니다. 테마의 업데이트가 반드시 필요하죠.



워드프레스 쇼핑몰 만들기 책을 보시는 분들도 우커머스를 2.1 버전으로 사용하면 안됩니다. 2.0 버전을 사용해서 완성된 데모 사이트에 2.1 버전으로 업데이트 했더니 위처럼 엉망으로 나옵니다. 이처럼 쇼핑몰을 상당한 부분을 커스터마이징 한 경우는 2.1 버전을 사용할 경우 다시 디자인해야 하므로 업데이트를 하지 않는 것이 좋습니다. 그러니 책을 보시는 분들은 이전 버전인 2.0.20을 사용해야 합니다. 위 데모 사이트의 테마는 나중에 2.1 버전으로 업그레이드 해서 첨부 파일에 올려놓겠습니다.


저작자 표시 비영리 변경 금지
신고
BlogIcon GAHOEDONG 60

워드프레스 관련 좋은글 많이 남겨주셔서 감사합니다!
우커머스 처음 사용자인데요.. 2.1 버전을 깔았더니 아직 여러모로 준비가 안되어 그런지 문제가 많네요 ㅠㅠ 2.0.x 버전을 받으려고 웹사이트 검색하다 지쳤습니다..ㅠㅠ
혹시 어디서 다운받는지 알려주실 수 있나요? 그럼 너무 감사하겠습니다!!

BlogIcon 베누시안

http://martian36.tistory.com/1334

위 링크를 참고하세요.

호두과자

안녕하세요. 책으로 열심히 공부중인 사람입니다.

쇼핑몰을 책을 이용해서 거진 다 만들었는데. 이니시스 결제플러그인을 사용해야 되는 상황입니다.

근데 이니시스는 우커머스 2.1 버전 이상에서만 지원이 되더군요.

우커머스를 업데이트 하면 레이아웃이 크게 깨지는 상황이고.. ㅠㅠ 큰 난관에 봉착했습니다.

해결책이 없을까요?

BlogIcon 베누시안

답변이 늦었습니다. 이니시스 플러그인 개발 업체가 더 있으니 지원되는지 확인하고 사용해보세요.

호두과자

답변 감사합니다.
다른 문의가 있는데 책에 있는 테마는 2.0~버전인데 혹시 깨지지않게끔 업데이트 하는 강좌 올리실 생각 없으신가요?

(책내용 질문인데 이곳에 남겨서 죄송합니다. 근데 이메일 인증했는데도 로그인이 되질 않네요..ㅠㅠ)

BlogIcon 베누시안

이메일을 알려주세요. 그리고 책은 하나의 테마를 이용해 커스터마이징 하는 방법을 알려주기 위한 것입니다. 책 내용대로 익히면 혼자서도 새버전의 우커머스나 테마로 새롭게 만들 수 있습니다. 시간이 나면 모두 새 버전으로 만들어서 올리겠습니다. 다만 방법을 올리기는 어렵습니다.

비밀댓글입니다

티스토리 툴바